You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

40 lines
1.6 KiB
Bash

# Maintainer: Joey Dumont <joey.dumont@gmail.com>
# Maintainer: Bjorn Neergaard <bjorn@neersighted.com>
# Contributor: Danny Su <contact@dannysu.com>
pkgname=duplicati-latest
pkgver=2.0.4.11
pkgrel=1
pkgdesc='A free backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers'
url='http://duplicati.com'
license=('LGPL')
install=duplicati.install
source=(https://github.com/duplicati/duplicati/releases/download/v2.0.4.11-2.0.4.11_canary_2019-01-16/duplicati-2.0.4.11_canary_2019-01-16.zip
duplicati-user.service
duplicati.service
duplicati.sysusers
duplicati-cli)
sha256sums=('5c81aa4264094d8547b2c3c4d3f2af6afbaa27e7e695bfdf5b23642429718625'
'2eb973cef79731d407bfbc83f754cef588c62ec83dae2112ac93f9c9f0baa403'
'499eb63532bcad50b897c0874b723eebc6693816fcb9626532f367b5ff51da70'
'b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959'
'f6f903ca443935314afeab4cd2e46cf4bef7c5fb1e81c2d95f670f0993774ce5')
arch=('i686' 'x86_64')
depends=('gtk-sharp-2' 'mono')
package() {
# Install the service.
install -Dm644 duplicati.service "${pkgdir}/usr/lib/systemd/system/duplicati.service"
install -Dm644 duplicati-user.service "${pkgdir}/usr/lib/systemd/user/duplicati.service"
install -Dm644 "$srcdir/duplicati.sysusers" "$pkgdir/usr/lib/sysusers.d/duplicati.conf"
rm duplicati.service duplicati-user.service
# Install the program.
rm *.zip
mkdir -p "${pkgdir}/opt/duplicati-latest"
cp -r . "${pkgdir}/opt/duplicati-latest"
mkdir -p "${pkgdir}/usr/bin"
install -D -m755 duplicati-cli "${pkgdir}/usr/bin"
}